HomeLatest ThreadsGreatest ThreadsForums & GroupsMy SubscriptionsMy Posts
DU Home » Latest Threads » Forums & Groups » Main » Announcements (Group) » We could use your help tr...

Fri Jul 31, 2020, 06:20 PM

We could use your help tracking down a bug... (UPDATE)

Last edited Fri Jul 31, 2020, 07:27 PM - Edit history (3)

This discussion thread was locked by EarlG (a host of the Announcements group).

Hi everyone,

UPDATE:

Thanks for your replies -- most helpful. We have temporarily rolled back the update while we work on a few things, so pages should now be displaying correctly. We're going to try this again sometime tomorrow.

We expect to be able to fix the issue with characters showing up incorrectly. With regard to the ads, we are testing new placements at the moment, so if you are not a Star Member, ads may show up in places where you weren't used to seeing them before. We're trying to balance this out as best we can so that it doesn't interfere with the experience that you're used to.

As for the other issues that were reported in this thread, I'm not 100% sure that they're related to this recent update, but we'll definitely check into it.

Thanks again for all your help, and your patience while we mess around with this stuff. I know it's super annoying (trust me, I would rather not be doing this on a Friday night, lol!)


ORIGINAL POST:

As you know we've been making some behind-the-scenes updates to the software this week which we anticipated could cause some problems. Unfortunately, we weren't exactly sure what the problems would be until we completed the updates.

Now we're getting an idea, however. Some people are currently seeing strange characters displayed in posts (typically where smart quotes would be used). Others are seeing too many ads. Some lucky folks are experiencing both problems simultaneously.

We can (and will) roll back the update, but it would be really helpful to gather some data before we do.

If you're having one (or both) of these problems, could you reply to this thread and let us know whether you are on desktop or mobile, and which browser you're using? It would be a big help.

Thanks,
The Administrators

50 replies, 6816 views

Cannot reply in locked threads

Back to top Alert abuse

Always highlight: 10 newest replies | Replies posted after I mark a forum
Replies to this discussion thread
Arrow 50 replies Author Time Post
Reply We could use your help tracking down a bug... (UPDATE) (Original post)
EarlG Jul 2020 OP
Fiendish Thingy Jul 2020 #1
Squinch Jul 2020 #2
skylucy Jul 2020 #3
soothsayer Jul 2020 #4
stonecutter357 Jul 2020 #5
Clash City Rocker Jul 2020 #6
chillfactor Jul 2020 #7
gratuitous Jul 2020 #8
33taw Jul 2020 #9
Laelth Jul 2020 #10
old guy Jul 2020 #11
TreasonousBastard Jul 2020 #12
cayugafalls Jul 2020 #13
Midnight Writer Jul 2020 #14
Rebl2 Jul 2020 #15
AleksS Jul 2020 #16
SheltieLover Jul 2020 #17
FM123 Jul 2020 #18
NCjack Jul 2020 #19
wcast Jul 2020 #20
magicarpet Jul 2020 #21
EarlG Jul 2020 #26
magicarpet Jul 2020 #37
magicarpet Jul 2020 #40
ProfessorGAC Jul 2020 #38
2naSalit Jul 2020 #22
EarlG Jul 2020 #28
2naSalit Jul 2020 #32
discntnt_irny_srcsm Jul 2020 #23
kentuck Jul 2020 #24
blaze Jul 2020 #25
nolabear Jul 2020 #27
EarlG Jul 2020 #29
2naSalit Jul 2020 #30
50 Shades Of Blue Jul 2020 #31
sarcasmo Jul 2020 #33
MyNameGoesHere Jul 2020 #34
Progressive Jones Jul 2020 #35
callous taoboy Jul 2020 #36
ProfessorGAC Jul 2020 #39
Lars39 Jul 2020 #41
c-rational Aug 2020 #42
in2herbs Aug 2020 #43
EarlG Aug 2020 #44
in2herbs Aug 2020 #48
EarlG Aug 2020 #49
in2herbs Aug 2020 #50
Miigwech Aug 2020 #45
EarlG Aug 2020 #46
bif Aug 2020 #47

Response to EarlG (Original post)

Fri Jul 31, 2020, 06:22 PM

1. Apostrophe and quotation marks garbled into odd characters

I’m on an iPad with up to date IOS (also iPhone)

^ apostrophe above is garbled

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:23 PM

2. On my laptop in DuckDuckGo, I'm getting those weird characters. (I use Firefox, if that matters.)

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:23 PM

3. I am seeing lots of strange characters in posts AND also having lots of ads popping up and obscuring

my view of the website. The strange characters in posts is making them almost unreadable. I am on my Apple laptop.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:25 PM

4. Both issues, new iPhone SE with latest iOS and safari

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:25 PM

5. K&R

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:26 PM

6. On an iPad, using Chrome

I see the ads. The problem is that they show in the middle of the page, obscuring posts, and there’s no apparent way to close them.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:26 PM

7. Use Chrome as my browser......on my HP laptop.

Leaving DU for now.....just too frustrating right now. Everytime I click on a DU post I get a screen at the bottom of my laptop screen that blocks out portions of posts. Have to cliick x to get rid of dang screen. Also I don't see any ads.....what I have instead is blank boxes wiith circles in the middle of blank boxes.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:26 PM

8. Yes on both

Smart quotes are coming through as gobbledygook, and ads are practically filling the screen when they aren't covering significant portions of the content. Updates are always such a pain. Hang in there.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:27 PM

10. I had both problems yesterday, but only briefly.

They’re gone today.

Apple OS 13.5.1 on iPhone 6s

-Laelth

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:27 PM

11. I have both problems.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:29 PM

12. Opera on a Win 10 laptop-- I'seen the comments, but no problems on my end.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:30 PM

13. Just an FYI, some ad blockers cause pages to load oddly.

They cause lags, page format problems, twitter threads to not appear and other odds and ends.

I had to disable mine and decided to donate to get rid of ads.

I suggest not using them. I know some people don't like ads, but I have been a long time IT person and noticed some errors are related to ad blockers or browser extensions that modify page code on the fly while loading.

This is not related to the problem of ads showing up oddly for people without a star or an ad blocker, only for people running ad blockers.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:31 PM

14. Windows 10 and Chrome on a desktop. No problems.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:33 PM

15. I am seeing

strange characters like question marks where they don’t belong. I am using an IPad and use safari browser.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:35 PM

16. I'm on a laptop using Chrome and saw the question mark and other characters

substituted for apostophes.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:39 PM

17. Both yesterday

All good today.

TYVM!

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:41 PM

18. I am on a laptop, going through Chrome.

I too am seeing weird almost cute looking squirrly characters.....

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:41 PM

19. I had a problem. My system is Mac Mini, Catalina Safari. the 3 character string .")

or was it .)" became a smilie.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:42 PM

20. I'm having both problems.

On mobile and using Firefox. Multiple weird characters where apostrophes would be.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:45 PM

21. Are you folks aware that a second/double (same) comment to a post can now be entered ?

Before the update if a second/double of the same comment was attempted the system would prevent the double and notify with a yellow page notice that the double post was automatically blocked.

The system since the update now allows the double post to the same thread.

*****

See link below for sample:

https://www.democraticunderground.com/100213831569

Note comments 7 & 8

*****
Mobile/cell
Android - OS
Google - browser service
*****

---------
Attempted to notify Elad 7/30 - but no response.
---------

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to magicarpet (Reply #21)

Fri Jul 31, 2020, 06:55 PM

26. Hmm, good to know

I think it's still technically possible to get in an accidental double post even with the software attempting to catch such a problem, so I'm not sure that's related to the current issue, but we'll check it out.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Reply #26)

Fri Jul 31, 2020, 07:22 PM

37. This is the second time that happened in the last couple of days.

The first time I just removed the double comment thinking you folks were in the middle of your reset/update. Once completed it would resort to the auto no double post feature block - yellow page notice that the system prevented the dual post of the same comment.

Once your reset was done, and the system allowed the double comment, I then notified Elad.

That auto block is a nice feature because it prevents the page from getting cluttered up. If you are busy multi tasking, on DU making comments, are pulled away, then come back to continue, but can not remember if you posted the comment yet, that yellow page notice the double was blocked serves notice that it was previously already posted.

If one is sorta/kinda (scatterbrained) that is a helpful feature.

Also too, on the other end, when one makes a new thread, it would be nice if the auto system block feature jumped in there to prevent a side by side posting of the exact same thread by the same person who made the initial thread posting.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to magicarpet (Reply #37)

Fri Jul 31, 2020, 07:38 PM

40. Oh,.. let me mention,

Your system has never allowed a back to back double comment post by me ever. It has always caught the double post, then notified that the double post was blocked via the yellow page notice.

This goes back years of blocking any inadvertent double comment posting by me... ever.

Just until this recent update.

(Is it against the law to give you folks a Valentine ? I just love DU !)

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to magicarpet (Reply #21)

Fri Jul 31, 2020, 07:35 PM

38. I've Seen Three Other Like That

I saw your double up, mc and it was one of 4.
I can't remember the topics so I tried to look for read threads.
But, I couldn't find them.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:46 PM

22. Yesterday...

This happened along with pages just not loading which was happening earlier today.

I had opened a thread in a new tab and when that page opened, there was a message banner about site maintenance but at the top of the page where it shows where I'm signed in, it was showing another user name instead of mine which I found very odd. I closed it and came back to see if they were even responding to the thread, which they were but it was then showing my own acct user name.


I did notify the other user to let them now that happened on case something unusual was happening for them.

That's all I know, man.





Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to 2naSalit (Reply #22)

Fri Jul 31, 2020, 06:56 PM

28. Thanks

We were able to catch and fix that one very quickly -- it's no longer a problem.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Reply #28)

Fri Jul 31, 2020, 07:01 PM

32. Hasn't happened again, thanks!

See my other post as some "post my reply" issues are happening. I'm om Firefox with ghostery and Avast protections. (WIN7).

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:48 PM

23. Ciao EarlG; Win7: Firefox & Chrome - no issues on either browser

HTH

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:51 PM

24. The "password" should disappear if user is not signed in...

It doesn't go away?????

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:54 PM

25. Laptop using Chrome. Seeing odd characters. I use Adblock. nt

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:56 PM

27. An altogether different weird issue.

I was getting ads, but that seems to have corrected. But I access on my iPhone and suddenly the subject lines turn bright red when I touch them. I can make it go back to the usual “this has been looked at” color but it’s certainly odd!

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to nolabear (Reply #27)

Fri Jul 31, 2020, 06:58 PM

29. Yes that happened to me too

It appeared to be a cosmetic issue, so not a top priority, but I did notice it. Will add it to the list

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:58 PM

30. Also yesterday and today...

Sometimes when I respond to an OP, when I hit "post my reply" it just hangs there frozen. If I hit the button again I get the "you've already posted your reply" screen. So if I go back to the OP before I replied, my comment is already there and when I close the page and go back to it.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 06:58 PM

31. Seeing the strange characters, on Win 10 laptop/Firefox 79.0 nt

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 07:04 PM

33. Chromebook, no issues.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 07:05 PM

34. Loads slow.

Hangs for a few seconds. Not seeing this with other websites. Android 11 phone.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 07:05 PM

35. I'm seeing it on my desktop. nt

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 07:10 PM

36. It is showing up on my laptop but not my I-Mac

I am using Safari 13.1.1 on the laptop.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 07:37 PM

39. I'm Seeing None Of What's Described Above

And I'm still using Chrome 76 on Android 6.0.1.
(Yeah, I'm not diligent about updates)

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Fri Jul 31, 2020, 10:54 PM

41. Titles turn red in Forum & Group page

when I click on them using my I-Phone.
Also happens to the titles in each forum.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Sat Aug 1, 2020, 10:26 AM

42. I am using a Samsung Tablet and Chrome. No weirdness, but i do note that when in the Latest

Threads and hit the < button from one post to go page to the Latest Threads it now updates automatically. Just a change. i liked the old system better where you had to hit the Tab at top to refresh and get the Latest Post., but am recognizing my habits - sometimes it is best to get use to the new.

Thankis for all your work.

Upeate - This am it seems to be back to normal.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Sun Aug 2, 2020, 03:01 PM

43. It's 8/3 and am reporting that my DU screen is still hosed. The left column is blank except for a

green arrow that goes non-stop around in a circle never producing that part of the site. The section where you read the articles is cut off at the bottom with another non-stop green circling arrow. My browser is Firefox. None of this was occurring before the Friday "fix." Thanks.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to in2herbs (Reply #43)

Sun Aug 2, 2020, 04:04 PM

44. What device/operating system/browser?

Thanks.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Reply #44)

Sun Aug 2, 2020, 06:24 PM

48. Firefox. Windows 10. thnx. nt Edit date: 8/2

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to in2herbs (Reply #48)

Sun Aug 2, 2020, 06:28 PM

49. Thanks for the info

I appreciate it.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Reply #49)

Mon Aug 3, 2020, 08:59 AM

50. My viewing of the DU site is working this AM (8/3) like it should. Thnx. nt

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Sun Aug 2, 2020, 04:31 PM

45. My page is acting strange.

 

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to Miigwech (Reply #45)

Sun Aug 2, 2020, 04:37 PM

46. In what way is it acting strange?

Can you please tell me what device/operating system/browser you are using?

Thanks.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink


Response to EarlG (Original post)

Sun Aug 2, 2020, 05:31 PM

47. I'm on a Mac Book Pro using Safari

And the ads are on the top, side, and bottom of the screen.

Cannot reply in locked threads

Back to top Alert abuse Link here Permalink